Erste Bugfixes beim GalleryTest

Nach dem „Release“ meines GalleryTest erschlugen mich gleich zwei Fehler von denen ich dachte, dass ich sie „nicht hätte“.

Während unter die Seite unter Localhost einwandfrei läuft, gab es Probleme wenn sie auf meinem WebServer lief.

Das erste Problem war einfach zu lösen. Unter  Opera scheint das AutoSuggest unter localhost abgeschaltet zu sein. Sobald die Seite „real“ gehostet zu werden, fuscht dieses AutoSuggest einem dazwischen. Denn es fängt die KeyUp-Events ab.  Einfach das entsprechende Attribut setzten und das Problem ist gelöst.

Das interessantere Problem brachte mir jedoch (wär hätte es anders erwartet) der IE (v8) ein. Ich hab schon damit gerechnet das der IE und der Rest der Browser-Welt Unterschiede herausstellen. Das der IE aber CSS unterschiedlich parsed in Abhängigkeit wo die Seite aufgerufen wird, dass war mir neu.

Stein des Anstoßes war die SuggestBox. Dieser „ausgeblendete“ Div-Container sollte sich mittels z-Index über alle anderen Container legen. Das funktionierte auch so weit ganz gut, bis ich die Webseite im IE öffnete und auch nur wenn sie nicht unter localhost lief.

Das Problem scheint zu sein, dass der GoogleMaps-Container in der Hauptebene liegt, und die SuggestBox in einen anderen Container geschachtelt ist. Diesem Container ist jedoch keine „Tiefe“ zugewiesen. Nachdem ich das geändert hatte, lief die Seite auch unter dem IE einwandfrei.

Interessanter ist, dass der Firefox meine inline-Scriptes komplett ignoriert. Da werd ich nochmal hirnschmalz reinstecken…